Xpoint
   [напомнить пароль]

Нет файлов PPD в архиве модулей DBI и DBDmysql

Метки: [без меток]
2007-07-16 10:19:24 [обр] Gumbert[досье]
Подскажите пожалуйста, как подключить модули DBI и DBDmysql, у меня не получается проинсталиировать модули: когда я запустил PPM и пишу install путь к файлу: пишет вот что: could not locate ppd file for package DBI. Смотрю в папку, там действительно нет файла pdd, скачал множество версий модуля с всевозможных ссылок, но нигде нет файлов ppd. Кто нибудь может дать 100% ссылку на модуль с файлом ppd.
Помогите пожалуйста!
спустя 26 минут [обр] Роман Чемисов(36/350)[досье]
Gumbert[досье]
Для этого нужно знать Вашу версию perl. А вообще для этих целей есть специальное средство — PPM. В последних версиях он даже графический, так что никаких проблем возникнуть не должно.
спустя 15 минут [обр] Gumbert[досье]
Я установил Active Perl 5.6.1 Build 638, с PPM работал через командную строку.
спустя 1 час 56 минут [обр] Роман Чемисов(36/350)[досье]
Gumbert[досье]
Так Вы сделайте search DBI, а потом уже install номер_результата
спустя 56 минут [обр] Gumbert[досье]
Он выдал множество сообщений, примерно таких:
ppm3-bin: 3 DB...
g XML...
и т. д. Мне это ничего не говорит.
Среди них нет PDD файлов.
Почему просто не найти файл модуля с PPD?
спустя 1 час 1 минуту [обр] Spectrum2(4/26)[досье]
Gumbert[досье]В командной строке пишите cpan, затем install DBI, затем install DBD::mysql
спустя 15 часов [обр] Роман Чемисов(36/350)[досье]
Gumbert[досье]
Странно... Нужные Вам файлы есть, например, здесь: ActivePerl builds 6xx
Powered by POEM™ Engine Copyright © 2002-2005