Xpoint
   [напомнить пароль]

Настроийка PHPEclipse + xdebug

Метки: [без меток]
2008-09-30 18:34:13 [обр] Winner[досье]

Приветствую всех!
Пожалуйста, помогите настроить PHPEclipse + xdebug на WV. xdebug устанолен и в phpinfo() отображается . DBG в системе нет.

php.ini:
zend_extension_ts=php_xdebug-2.0.3-5.2.5.dll
xdebug.remote_enable=On
xdebug.remote_autostart=On
xdebug.remote_handler=dbgp
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.remote_mode=req

httpd.conf:
<VirtualHost localhost>
DocumentRoot C:/sites/localhost
ServerName localhost
</VirtualHost>

hosts:
127.0.0.1 localhost


ProjectName= localhost
Project defaults:
- project URL= http://localhost
- DocumentRoot= C:\sites\localhost
Xdebug:
- Debugport= 9000
- PHP Interpreter= C:\php\php.exe

DebugMain:
-Name= Remote_xdebug
-Project= localhost
-Ide Identification String= testID

DebugPathmap:
- Local= C:\sites\localhost
- Remote= C:/sites/loclhost

/xdebug.php:
<?
$num =100;
for ($i =1; $i <= 10; $i++){// на этой строке прерыватель
  print (" we are at ". $num+$i. "<br />");
}
?>

Запускаю дибаг Remote_xdebug. В резултате лишь появляется в окошечке Debug это:
Remote_xdebug [PHP Xdebug Remote Script]
PHP Xdebug Client at loclhost:9000

Через FireFox захожу на http://localhost/xdebug.php?XDEBUG_SESSION_START=testID.
В резултате получаю:
we are at 101
we are at 102
we are at 103
we are at 104
we are at 105
we are at 106
we are at 107
we are at 108
we are at 109
we are at 110

Тоесть какого либо дибагинга не наблюдается. Как решить проблему?

спустя 6 месяцев [обр] Winner[досье]
Здравствуйте!
Ребята, пожалуйста, помогите настроить какой нибудь дибаггер в PHPEclipse. Какие ни настраивал ни один не работает. Пожалуйста отзовитесь кто работает в этой среде и с каким дибаггером.
спустя 1 час 27 минут [обр] Winner[досье]
Извиняюсь, не указал существенную деталь: ОС Windows Vista.
Powered by POEM™ Engine Copyright © 2002-2005