Xpoint
   [напомнить пароль]

Как помирить firefox и disable-output-escaping?

Метки: [без меток]
[удл]
2009-07-24 12:51:50 [обр] Artem[досье]
Как помирить firefox и disable-output-escaping? В xsl-файле указываю этот параметр, Опера и ИЕ выводят как и ожидал, ФФ упорно преобразует всё в спецсимволы (< > и тому подобное)? Вообще проблема решаема?
спустя 2 дня 4 часа [обр] Евгений Дест(0/49)[досье]
Короткий пример в студию.
спустя 12 часов [обр] Artem[досье]

легко :)

xml:

<info type="default" title="some title">
 <![CDATA[
<p><img src="images/back_header.jpg" class="f_left"/>тра-ля-ля <b>толстый текст</b></p>
<p>Добро пожаловать на тестовую страницу <img src="images/back_header.jpg" class="f_right"/>этого сайта!!!</p>
]]>
</info>

xsl:

<xsl:apply-templates select="document('content.xml')//info" />

<xsl:template match="info">
   <xsl:value-of select="." disable-output-escaping="yes"/>
</xsl:template>

Вот, не работает только в ФФ, то есть работает, но вывод без изменений он понимает по своему: выводит всё в окно. Получается не браузер видит код без изменений, а пользователь, который смотрит на экран, а когда смотришь в исходный код, то там видишь что все скобки заменены на &lt; &gt;

спустя 3 дня [обр] Евгений Дест(0/49)[досье]
Это всё таки баг, и единственное решение которое я нашел, это использовать xsl:copy-of вместо xsl:value-of до тех пор пока это не исправят. Попробуйте и отпишите о результатах, пожалуйста.
спустя 4 дня [обр] Artem[досье]
да, xsl:copy-of решило проблему, спасибо большое
Powered by POEM™ Engine Copyright © 2002-2005