Xpoint
   [напомнить пароль]

Mozilla не отображает CSS

Метки: [без меток]
[удл]
2004-11-10 21:36:36 [обр] Дмитрий Четвериков(0/8)[досье]

День добрый.

Поставил вот себе мозиллу 1.7.3 и столкнулся с проблемой.
Если сайт берется из инета - все в порядке.
Если с локального веб-сервера, то не читаются CSS вообще.
Рядом у коллеги стоит 1.0 - там все в порядке.
Попробовал поискать настройки какие-то в мозилле - вроде ничего касающегося таблицы стилей не нашел...
Может кто сталкивался? Даже идей нет отчего такое может быть хотя бы теоретически :(

Заранее спасибо.

спустя 14 часов [обр] Владимир Палант(49/4445)[досье]
Content-Type правильный отдаётся? Mozilla не обрабатывает CSS с неправильным Content-Type, должен быть text/css.
спустя 3 часа 1 минуту [обр] Дмитрий Четвериков(0/8)[досье]
Естественно все правильно - я же говорю - один и тот же сайт он показывает из нета нормально, по локалке - без стилей (при чем эксплорер стили отображает совершенно нормально). Хфантастика.
спустя 25 минут [обр] Алексей В. Иванов(9/2861)[досье]
Дмитрий Четвериков[досье] Это относится только к одному сайту или ко всем?
спустя 48 минут [обр] Сергей Круглов(33/2057)[досье]
Вы упомянули, что смотрите сайт с локального сервера... Что за сервер?
спустя 2 часа 32 минуты [обр] Владимир Палант(49/4445)[досье]
Дмитрий Четвериков[досье]
Я понял так, что сайт всё-таки разный - во втором случае это локальный сервер и Content-Type (в заголовках HTTP) для CSS может быть неправильно настроен. IE игнорирует Content-Type, за что его регулярно ругают. Для Apache настройка выглядит к примеру так:
AddType text/css .css
спустя 4 дня [обр] Дмитрий Четвериков(0/8)[досье]

Алексей В. Иванов[досье]
ко всем

Сергей Круглов[досье]
Apache/1.3.31 (Unix) PHP/4.3.8 rus/PL30.20

Владимир Палант[досье]
ок. спасибо - попробую.

Powered by POEM™ Engine Copyright © 2002-2005