Xpoint
   [напомнить пароль]

Вложенные клипы

Метки: [без меток]
2009-02-14 16:19:22 [обр] Lana[досье]

Добрый день, у меня есть мувик (index) в нем - меню + пустой клип (content), в который вот так загружается вторая страница-мувик (temp2):

on (release) {

   _root.content.loadMovie("temp2.swf");
}

В этом втором загружаемом мувике тоже есть меню, в котором навигация реализуется вроде по такому же принципу:
on (release) {

   _root.content.loadMovie("other.swf");
}

но третий мувик ("other.swf") в итоге не подгружается в первый. Если смотреть второй мувик (temp2.swf) как отдельный клип, то третий клип ("other.swf") в него корректно подгружается, а вот в мувике (index) линки работают только до второго уровня, а дальше ничего не происходит. Подскажите, что нужно дописать в _root.content.loadMovie("other.swf");, чтобы он открывался в мувике (index)?

спустя 7 часов [обр] Евгений[досье]
Насколько я понял, в temp2.swf тоже есть пустой клип (content)? Если это так, то в temp2.swf надо писать _root.content.content.loadMovie("other.swf"); - 1-ый content - обращение к пустому клипу в index, второй - к пустому клипу в temp2.swf.
Если же Вы оставляете в temp2.swf _root.content.loadMovie("other.swf"); , то у Вас в главном клипе (index) загруженный сначала клип temp2.swf просто заменится на other.swf.
Испробовал на Flash 9, ActionScript 2
спустя 54 минуты [обр] Lana[досье]
Ура, большое спасибо, работает!!!
спустя 4 дня [обр] Lana[досье]
Вопрос вдогонку: у меня вроде все работает, когда я тестирую из flash-a , а когда проигрывается отдельный swf. файл (index.swf), то последний вложенный клип (other.swf) не открывается, ну и то же самое происходит, когда этот index.swf интегрирован в html. На что мне обратить внимание? у меня могут быть проблемы с самим плэером, потому что с относительными путями порядок...
спустя 3 часа 26 минут [обр] Алексей В. Иванов(276/2861)[досье]
Проблема с путями
Powered by POEM™ Engine Copyright © 2002-2005