Xpoint
   [напомнить пароль]

WiFi не пингуется

Метки: [без меток]
[арх]
2009-03-09 13:21:22 [обр] Александр М(0/4)[досье]

Две PCI D-Link DWA-510 переведены в режим Ad-hoc, назначены IP из одной подсети. SSID одинаков, шифрование отключено совсем, брандмауэр отключен (служба тоже остановлена), стоял КИС 2009, но я его тоже на всякий случай удалил. Мощность сигнала колеблется от "Отличный" до "Очень хороший". Для настройки сети используется Windows (как с помощью родного ПО настроить режим компьютер-компьютер я не понял). В общем карточки коннектятся друг с другом, но пинга нет. Голову сломал - не пойму в чем дело. Кто-нибудь сталкивался с подобным?

p.s.: на одном из ПК есть еще одна сетевая карта, смотрящая в локальную сеть - работает отлично.

спустя 20 часов [обр] LookeR(31/1069)[досье]
Есть ли разница с включенной/с отключенной сетевой картой?
Нет ли каких прошивок? Обновлений драйверов?
спустя 1 час 4 минуты [обр] Алексей Севрюков(9/1292)[досье]
Александр М[досье] когда я последний раз сталкивался с такой проблемой оказалось что коннектился я не к тому девайсу, и в итоге пинга не было ) Убедитесь что вы коннектитесь куда надо и проверьте так же настройки сети.
спустя 12 часов [обр] Александр М(0/4)[досье]

Я, продолжил работу, не имея возможности прочесть ваши комментарии. Поэтому расскажу, что получилось, а потом попробую отключить проводную сетевую.

Несмотря на отсутствие пинга, я на ПК1 (где wi-fi1 и lan1) объединил две эти сетевые мостом. Прописал мосту IP из той же подсети, что и у wi-fi1/wi-fi2 и у lan1. И эти два ПК тут же начали пинговаться по wi-fi. На отдельно стоящем ПК2 (на котором работал только беспроводной интерфейс) заработала внутренняя сеть и интернет. Почему это произошло - для меня загадка.

Причем сеть работала, только при отключенном шифровании и, только в режиме «b only», т.е. на 11 Мбитах. В режиме «g only» (устанавливал на обоих ПК) на ПК1 наблюдал обрывы соединения каждые 5-10 сек. После чего он автоматически его восстанавливал и по прошествии нескольких секунд оно снова обрывалось. При включении шифрования, ситуация возвращалась к описанному в первоначальном посте — коннект есть, а пинга нет.

Интернет и сеть на ПК2 (через wi-fi) работают ощутимо (в разы) медленнее, чем на ПК1 через кабель. Хотя, если открывать сайты на ПК2 по IP, а не по имени, то, субъективно, скорость такая же, как на ПК1. Видимо тут, что намудрилось у меня с DNS. Пинг между двумя беспроводными интерфейсами нестабилен — примерно 17% потерь (это я про «b», т.к. в режиме «g» вообще не работает).

Расстояние между антеннами метров 7, а отгораживает их гипсокартонная перегородка с дверным проемом. Дверь все время открыта.

В связи с этим у меня уточнения к вопросу. Проблема вроде решена — пинг появился, но:
 — работает только «b only»;
 — ПК2 по сети работает медленно;
 — отсутствует шифрование;
 — и я не знаю, как уменьшить мощность антенн и сократить потери.

Буду признателен любым мыслям по последнему абзацу и по организации соединения.


КОНФИГУРАЦИЯ


ПК1:
 — lan1 (смотрит на концентратор, в который воткнут DSL-модем с IP 192.168.0.254):
    IP 192.168.0.41, маска 255.255.255.0, шлюз 192.168.0.254, dns 192.168.0.254
 — Wi-Fi1 (смотрит на Wi-Fi2 ПК2):
    IP 192.168.0.42, маска 255.255.255.0, шлюз 192.168.0.254, dns 192.168.0.254
 — мост (объединены lan1 и wi-fi1):
    IP 192.168.0.40, маска 255.255.255.0, шлюз 192.168.0.254, dns 192.168.0.254


ПК2:
 — lan2 (отключен постоянно)
 — Wi-Fi2 (смотрит на Wi-Fi1 ПК1):
    IP 192.168.0.45, маска 255.255.255.0, шлюз 192.168.0.254, dns 192.168.0.254


p.s.:
LookeR[досье]:

Нет ли каких прошивок? Обновлений драйверов?

 Простите, не понял вопроса. Драйвера на wi-fi стоят родные из коробки. Я, правда, после того как намучался, то удалил родное ПО и настраивал средствами Windows. Про прошивки, уточните, пожалуйста. Лично я ничего не прошивал и сомневаюсь, что без меня кто-то это делал. Как узнать?

Алексей Севрюков[досье]:

Убедитесь что вы коннектитесь куда надо и проверьте так же настройки сети.

 Хотел бы я, чтобы Вы оказались правы! :) Уточните, пожалуйста, что именно Вы рекомендуете проверить в настройках сети.

Благодарю.

спустя 1 час 39 минут [обр] LookeR(31/1069)[досье]

Прошивок для этих моделей нет, а драйвера посмотрите:
http://ftp.dlink.ru/pub/Wireless/DWA-510/Drivers/

Пропишите адреса DNS-серверов непосредственно на ПК2, а не ссылайтесь на ПК, как DNS-сервер. Думаю, что так будет быстрее.

спустя 7 часов [обр] Алексей Севрюков(9/1292)[досье]

Александр М[досье] Проверять ничего не нужно, я по конфигурации сети вижу что у Вас с настройками все в порядке.
ИМХО, нужно купить DSL+WiFi роутер и забыть об этих извращениях.

Драйвера на wi-fi стоят родные из коробки. Я, правда, после того как намучался, то удалил родное ПО и настраивал средствами Windows. Про прошивки, уточните, пожалуйста. Лично я ничего не прошивал и сомневаюсь, что без меня кто-то это делал. Как узнать?

Дрова лучше скачать свежие с сайта производителя. Дрова в коробке далеко не всегда свежие. Прошивки для WiFi карточек врятли будут, а вот для роутеров и маршрутизаторов это обычное дело - тоже можете посмотреть, скачать и прошить свеженькую. Только настройки не забудьте записать перед прошивкой.

спустя 2 месяца 17 дней [обр] Александр М(0/4)[досье]

На сайте D-Link написано, что в режиме Ad-hoc карты поддерживают только стандарт 802.11b, т.е. работают на скорости до 11 Mbit. Значит с этим разобрались. Равно как и с медленной скоростью работы ПК2 в сети.

WEP-шифрование кое как тоже вроде удалось настроить.

Остался вопрос с мощностью - хотелось бы ее немного уменьшить. Чтоб этажом ниже и в соседних комнатах не ловилась. И появился еще один вопрос по теме: этот WiFi работает нестабильно. Утром компьютеры включили - работает. А через время связь пропадает. Такое ощущение, что карты отключаются после простоя. Такое возможно? Если «да» - то как избавиться, если «нет» - то, что еще может быть?

спустя 52 минуты [обр] Алексей Севрюков(9/1292)[досье]
Александр М[досье]
  1. Мощность - настраивается в диспетчере устройств, в свойствах карточки
  2. Да, возможно и по нескольким причинам. В том же диспетчере устройств отключите режимы энергосбережения и снимите галочку "разрешить отключать устройство для экономии энергии" (как то так). Если это не поможет то проблема либо в железе, либо в самой OS. Неоднократно сталкивался с подобными проблемами, постоянно теряется связь. Точную причину этого так и не нашел.
спустя 2 минуты [обр] Александр М(0/4)[досье]

Для нагладности скриншот (на ПК2) того, что происходит при пинге внешнего IP и беспроводной сетевой карты с которой установленно соединение (ПК1). КИС-2009 в это время остановлен.

  1. http://img6.imageshost.ru/imgs/090527/106fd75b99/18355.png
  2. http://img6.imageshost.ru/imgs/090527/ccc8e98fd0/eee62.png

Скриншот снят с двух окон одновременно.

спустя 7 минут [обр] Александр М(0/4)[досье]

Алексей Севрюков[досье]
К сожалению не нашел. Есть два пункта близких к тому, что Вы говорите:

  1. CAM when AC Power - установленно Disable
  2. Power Saving Mode - установленно CAM (Constatntly Awake Mode)

Во 2-м пункте еще есть MAX_PSP (Max Power Saving) и FAST_PSP (Power Save Mode)

спустя 17 минут [обр] Алексей Севрюков(9/1292)[досье]

Александр М[досье] англоязычной версии у меня под рукой нет, сейчас посмотрел у себя в свойствах устройства:

  1. Вкладка "Дополнительно", параметр "Выходная мощность", есть значения 100%, 75%, 50%, 25%. У Вас может быть по другому.
  2. Вкладка "Управление электропитанием". Галочка "разрешить отключение этого устройства для экономии энергии".

Как эти параметры называются у Вас я не в курсе.

спустя 28 минут [обр] Александр М(0/4)[досье]

Алексей Севрюков[досье] Кажется мощность нашел. У меня это на вкладке Дополнительно параметр Aggressive Roaming Condition, установлено Disable, но еще есть -60dbm, -70dbm, -80dbm, -90dbm. А вкладки «Управление электропитанием» в свойствах беспроводной сетевой платы у меня точно нет, хотя в свойствах проводной сетевой - имеется.

Что еще может быть с нестабильностью сигнала? При таком отвратительном пинге, мне, кажется, что причина может быть не только в управлении питанием. Можно еще, что-нибудь мне посоветовать?

спустя 6 часов [обр] LookeR(31/1069)[досье]
Канал подбирайте...
спустя 8 часов [обр] Алексей Севрюков(9/1292)[досье]
Александр М[досье] Это не мощность, это роуминг. Т.е. автоматическое переключение между разными сетями. Его лучше так и оставить - Disable.
спустя 6 часов [обр] Александр М(0/4)[досье]

LookeR[досье] Не поверите! Вчера разбирался со штатной программой и пытался там канал менять. Ничего не получилось. Все время висит на 6-м. Любой устанавливаю, но все равно использует 6-й. Так и не получилось сменить :(

Алексей Севрюков[досье]Понятно. Спасибо.

спустя 1 год 10 месяцев [обр] pvppya[досье]

Была такая же проблема. Wi-Fi не пинговался. Я по всякому пытался. Связь - сеть поднимает, а пинг не проходит.
Цитата: <Две PCI D-Link DWA-510 переведены в режим Ad-hoc, назначены IP из одной подсети. SSID одинаков, шифрование отключено совсем, брандмауэр отключен (служба тоже остановлена), стоял КИС 2009, но я его тоже на всякий случай удалил. Мощность сигнала колеблется от "Отличный" до "Очень хороший". Для настройки сети используется Windows (как с помощью родного ПО настроить режим компьютер-компьютер я не понял). В общем карточки коннектятся друг с другом, но пинга нет. Голову сломал - не пойму в чем дело. Кто-нибудь сталкивался с подобным?
p.s.: на одном из ПК есть еще одна сетевая карта, смотрящая в локальную сеть - работает отлично.>
Мои сетевые настройки.
PC1
LAN смотрит в инет ADSL режим роутер 192.168.0.2 Wi-Fi 192.168.2.2
                                     255.255.255.0 255.255.255.0
                                     192.168.0.1 192.168.2.1
                                                  
PC2 LAN отсутствует Wi-Fi 192.168.2.1
                                                              255.255.255.0
при обратной комбинации адресов для Wi-Fi, пинг не проходит.

Единственное отличие у меня TP-Link TL-W353GD buik 54M. Проблема была в том, что установил метку на (< > ключ подбирать автоматически ). Убрал галку, задал свой ключ и всё заработало. И 11 Мбит/с. и 54 Мбит/с. На первом режиме скорость передачи 500-600 Кбит/с. , на втором режиме 2000-2200 Кбит/с. Остался на втором в тестовом режиме, системники стоят рядом. Разнесу, там посмотрим.

спустя 2 минуты [обр] pvppya[досье]
Я, извиняюсь. Перед добавлением сообщение не просмотрел. Строки сдвинулись.
Powered by POEM™ Engine Copyright © 2002-2005